Ambra says I need Java to upload

If your system is asking you to download java, and for whatever reason you are unable to, try uploading using Google Chrome.  

Google Chrome no longer requires Java to upload because the browser has the capability built in.  This is a good work around for when security settings prohibit you from updating java on browsers like Internet Explorer and Mozilla Firefox.

Still need help? Submit Request Submit Request